Skip to end of metadata
Go to start of metadata

Summary

Release 4 of the Radio Edge Cloud blueprint contains only minor changes. As of Release 3 the Radio Edge Cloud blueprint has been very stable and most of the contributors focus has been within the O-RAN community rather than Akraino with enhancements to the RAN Intelligent Controller. As in Release 3, most of the code for REC is actually shared with its Telco Appliance (TA) family. The changes to Telco Appliance are mostly the version increments to the upstream projects listed below plus minor bug fixes and the bullet points listed below. Providing an integrated, automated deployment of an interoperable set of upstream projects is a major goal of REC and TA, so these version updates are the primary focus of the release.

Changes since Release 3 (2020-05-21)

New Features

  • Updated from pinned CentOS 7.6.1810 to latest CentOS 7 (currently 7.8.2003)
  • Rebalance root disk storage - move MariaDB onto its own volume and make /var/log receive all remaining space after other partition allocations are fulfilled

Fixes

  • Security: disable kubelet debugging handlers flag
  • Fix zipp version issue
  • Boot fixes: on Nokia hardware, boot first from (virtual) CD-ROM rather than floppy; on Dell hardware boot first from virtual, rather than physical, CD.
  • Remove deprecated XFS "nobarrier" mount option
  • BMC Exception handling

Versions of Selected Upstream Components

  • Docker 3:19.03.3
  • containerd 1.2.6
  • Helm 2.15.2
  • Kubernetes 1.16.2
  • DANM 4.1.0
  • Flannel 0.11.0
  • Elasticsearch 7.4.2
  • Fluentd 1.7.4
  • Prometheus 2.13.1

Full Package Listing

yum list from installed REC server
$ yum list
Loaded plugins: fastestmirror, priorities
Installed Packages
MySQL-python.x86_64                           1.2.5-1.el7                                 @centos-base
OpenIPMI.x86_64                               2.0.27-1.el7                                @centos-base
OpenIPMI-libs.x86_64                          2.0.27-1.el7                                @centos-base
OpenIPMI-modalias.x86_64                      2.0.27-1.el7                                @centos-base
PyYAML.x86_64                                 3.10-11.el7                                 installed
access-management.noarch                      c4.g34040e0-1.el7.centos.ta                 @akraino-ta
acl.x86_64                                    2.2.51-15.el7                               installed
activators.noarch                             c35.gc8427f2-1.el7.centos.ta                @akraino-ta
ansible.noarch                                2.4.4.0-1.el7.ans                           @centos-cloud
ansible-role-ntp.noarch                       0.4.0.2.g4fc673c-1.el7.centos.ta            @akraino-ta
apr.x86_64                                    1.4.8-5.el7                                 @centos-base
apr-util.x86_64                               1.5.2-6.el7                                 @centos-base
audit.x86_64                                  2.8.5-4.el7                                 installed
audit-libs.x86_64                             2.8.5-4.el7                                 installed
audit-libs-python.x86_64                      2.8.5-4.el7                                 installed
authconfig.x86_64                             6.2.8-30.el7                                installed
autogen-libopts.x86_64                        5.18-5.el7                                  @centos-base
avahi-libs.x86_64                             0.6.31-20.el7                               @centos-base
basesystem.noarch                             10.0-7.el7.centos                           installed
bash.x86_64                                   4.2.46-34.el7                               installed
bash-completion.noarch                        1:2.1-8.el7                                 @centos-base
bind-export-libs.x86_64                       32:9.11.4-16.P2.el7_8.6                     @centos-updates
binutils.x86_64                               2.27-43.base.el7_8.1                        @centos-updates
boost-program-options.x86_64                  1.53.0-28.el7                               @centos-base
boost159-atomic.x86_64                        1.59.0-2.el7.1                              @centos-cloud
boost159-chrono.x86_64                        1.59.0-2.el7.1                              @centos-cloud
boost159-date-time.x86_64                     1.59.0-2.el7.1                              @centos-cloud
boost159-filesystem.x86_64                    1.59.0-2.el7.1                              @centos-cloud
boost159-locale.x86_64                        1.59.0-2.el7.1                              @centos-cloud
boost159-log.x86_64                           1.59.0-2.el7.1                              @centos-cloud
boost159-program-options.x86_64               1.59.0-2.el7.1                              @centos-cloud
boost159-regex.x86_64                         1.59.0-2.el7.1                              @centos-cloud
boost159-system.x86_64                        1.59.0-2.el7.1                              @centos-cloud
boost159-thread.x86_64                        1.59.0-2.el7.1                              @centos-cloud
btrfs-progs.x86_64                            4.9.1-1.el7                                 installed
bzip2-libs.x86_64                             1.0.6-13.el7                                installed
ca-certificates.noarch                        2020.2.41-70.0.el7_8                        @centos-updates
caas-chartrepo.x86_64                         1.0.0-13.el7.centos.ta                      @akraino-ta
caas-cpupooler.x86_64                         0.3.1-15.el7.centos.ta                      @akraino-ta
caas-custom_metrics.x86_64                    0.5.0-4.el7.centos.ta                       @akraino-ta
caas-danm.x86_64                              4.1.0-2.el7.centos.ta                       @akraino-ta
caas-dynamic_local_pv_provisioner.x86_64      0.1.0-5.el7.centos.ta                       @akraino-ta
caas-elasticsearch.x86_64                     7.4.2-0.el7.centos.ta                       @akraino-ta
caas-etcd.x86_64                              3.4.3-1.el7.centos.ta                       @akraino-ta
caas-flannel.x86_64                           0.11.0-12.el7.centos.ta                     @akraino-ta
caas-fluentd.x86_64                           1.7.4-0.el7.centos.ta                       @akraino-ta
caas-helm.x86_64                              2.15.2-1.el7.centos.ta                      @akraino-ta
caas-hyperdanm.x86_64                         4.1.0-2.el7.centos.ta                       @akraino-ta
caas-infra-charts.noarch                      1.0.0-49.el7.centos.ta                      @akraino-ta
caas-instantiate.noarch                       1.0.0-25.el7.centos.ta                      @akraino-ta
caas-kubedns.x86_64                           1.15.7-1.el7.centos.ta                      @akraino-ta
caas-kubernetes.x86_64                        1.16.2-4.el7.centos.ta                      @akraino-ta
caas-lcm.x86_64                               1.0.0-9.el7.centos.ta                       @akraino-ta
caas-logging.noarch                           c20.g6b5969e-1.el7.centos.ta                @akraino-ta
caas-metrics_server.x86_64                    0.3.6-0.el7.centos.ta                       @akraino-ta
caas-prometheus.x86_64                        2.13.1-0.el7.centos.ta                      @akraino-ta
caas-registry.x86_64                          2.7.1-12.el7.centos.ta                      @akraino-ta
caas-security.x86_64                          1.0.0-11.el7.centos.ta                      @akraino-ta
caas-sriovdp.x86_64                           3.1.0-1.el7.centos.ta                       @akraino-ta
caas-storage_local_static_provisioner.x86_64  2.3.3-1.el7.centos.ta                       @akraino-ta
caas-swift.x86_64                             2.23.1-1.el7.centos.ta                      @akraino-ta
caas-utils.noarch                             1.0.0-11.el7.centos.ta                      @akraino-ta
centos-indexhtml.noarch                       7-9.el7.centos                              @centos-base
centos-logos.noarch                           70.0.6-3.el7.centos                         @centos-base
centos-release.x86_64                         7-8.2003.0.el7.centos                       installed
ceph.x86_64                                   2:12.2.11-0.el7                             @centos-ceph
ceph-ansible.noarch                           3.1.10-1.el7                                @centos-ceph
ceph-base.x86_64                              2:12.2.11-0.el7                             @centos-ceph
ceph-common.x86_64                            2:12.2.11-0.el7                             @centos-ceph
ceph-mds.x86_64                               2:12.2.11-0.el7                             @centos-ceph
ceph-mgr.x86_64                               2:12.2.11-0.el7                             @centos-ceph
ceph-mon.x86_64                               2:12.2.11-0.el7                             @centos-ceph
ceph-osd.x86_64                               2:12.2.11-0.el7                             @centos-ceph
ceph-radosgw.x86_64                           2:12.2.11-0.el7                             @centos-ceph
ceph-selinux.x86_64                           2:12.2.11-0.el7                             @centos-ceph
checkpolicy.x86_64                            2.5-8.el7                                   installed
chkconfig.x86_64                              1.7.4-1.el7                                 installed
cloud-init.x86_64                             18.5-6.el7.centos.5                         @centos-updates
cloud-utils.x86_64                            0.27-20.el7.centos                          @centos-extras
cloud-utils-growpart.noarch                   0.29-5.el7                                  installed
config-encoder-macros.noarch                  master.624ed05-1.el7.centos.ta              @akraino-ta
config-manager.noarch                         c36.g8a3f88d-1.el7.centos.ta                @akraino-ta
container-selinux.noarch                      2:2.119.2-1.911c772.el7_8                   @centos-extras
containerd.io.x86_64                          1.2.6-3.3.el7                               @docker-ce-stable
coreutils.x86_64                              8.22-24.el7                                 installed
cpio.x86_64                                   2.11-27.el7                                 installed
cpp-hocon.x86_64                              0.1.6-9.el7                                 @centos-cloud
cracklib.x86_64                               2.9.0-11.el7                                installed
cracklib-dicts.x86_64                         2.9.0-11.el7                                installed
cronie.x86_64                                 1.4.11-23.el7                               installed
cronie-anacron.x86_64                         1.4.11-23.el7                               installed
crontabs.noarch                               1.11-6.20121102git.el7                      installed
cryptsetup.x86_64                             2.0.3-6.el7                                 @centos-base
cryptsetup-libs.x86_64                        2.0.3-6.el7                                 installed
curl.x86_64                                   7.29.0-57.el7_8.1                           @centos-updates
cyrus-sasl.x86_64                             2.1.26-23.el7                               @centos-base
cyrus-sasl-gssapi.x86_64                      2.1.26-23.el7                               @centos-base
cyrus-sasl-lib.x86_64                         2.1.26-23.el7                               installed
dbus.x86_64                                   1:1.10.24-14.el7_8                          @centos-updates
dbus-glib.x86_64                              0.100-7.el7                                 installed
dbus-libs.x86_64                              1:1.10.24-14.el7_8                          @centos-updates
dbus-python.x86_64                            1.1.1-9.el7                                 installed
dejavu-fonts-common.noarch                    2.33-6.el7                                  @centos-base
dejavu-sans-fonts.noarch                      2.33-6.el7                                  @centos-base
device-mapper.x86_64                          7:1.02.164-7.el7_8.2                        @centos-updates
device-mapper-event.x86_64                    7:1.02.164-7.el7_8.2                        @centos-updates
device-mapper-event-libs.x86_64               7:1.02.164-7.el7_8.2                        @centos-updates
device-mapper-libs.x86_64                     7:1.02.164-7.el7_8.2                        @centos-updates
device-mapper-multipath-libs.x86_64           0.4.9-131.el7                               @centos-base
device-mapper-persistent-data.x86_64          0.8.5-2.el7                                 @centos-base
dhclient.x86_64                               12:4.2.5-79.el7.centos                      installed
dhcp-common.x86_64                            12:4.2.5-79.el7.centos                      installed
dhcp-libs.x86_64                              12:4.2.5-79.el7.centos                      installed
dialog.x86_64                                 1.2-5.20130523.el7                          @centos-base
diffutils.x86_64                              3.3-5.el7                                   installed
distributed-state-server.noarch               c2.gbd5a0a1-1.el7.centos.ta                 @akraino-ta
dmidecode.x86_64                              1:3.2-3.el7                                 installed
dnsmasq.x86_64                                2.76-10.el7_7.1                             @centos-base
docker-ce.x86_64                              3:19.03.3-3.el7                             @docker-ce-stable
docker-ce-cli.x86_64                          1:19.03.3-3.el7                             @docker-ce-stable
dosfstools.x86_64                             3.0.20-10.el7                               @centos-base
dpdk.x86_64                                   18.11.8-1.el7_8                             @centos-extras
dpdk-tools.x86_64                             18.11.8-1.el7_8                             @centos-extras
dracut.x86_64                                 033-568.el7                                 installed
dracut-config-generic.x86_64                  033-568.el7                                 installed
dracut-config-rescue.x86_64                   033-568.el7                                 installed
dracut-network.x86_64                         033-568.el7                                 installed
driverctl.noarch                              0.108-1.el7_6                               @centos-extras
e2fsprogs.x86_64                              1.42.9-17.el7                               installed
e2fsprogs-libs.x86_64                         1.42.9-17.el7                               installed
elfutils-default-yama-scope.noarch            0.176-4.el7                                 installed
elfutils-libelf.x86_64                        0.176-4.el7                                 installed
elfutils-libs.x86_64                          0.176-4.el7                                 installed
erlang-asn1.x86_64                            19.3.6.4-1.el7                              @centos-cloud
erlang-compiler.x86_64                        19.3.6.4-1.el7                              @centos-cloud
erlang-crypto.x86_64                          19.3.6.4-1.el7                              @centos-cloud
erlang-eldap.x86_64                           19.3.6.4-1.el7                              @centos-cloud
erlang-erts.x86_64                            19.3.6.4-1.el7                              @centos-cloud
erlang-hipe.x86_64                            19.3.6.4-1.el7                              @centos-cloud
erlang-inets.x86_64                           19.3.6.4-1.el7                              @centos-cloud
erlang-kernel.x86_64                          19.3.6.4-1.el7                              @centos-cloud
erlang-mnesia.x86_64                          19.3.6.4-1.el7                              @centos-cloud
erlang-os_mon.x86_64                          19.3.6.4-1.el7                              @centos-cloud
erlang-otp_mibs.x86_64                        19.3.6.4-1.el7                              @centos-cloud
erlang-public_key.x86_64                      19.3.6.4-1.el7                              @centos-cloud
erlang-runtime_tools.x86_64                   19.3.6.4-1.el7                              @centos-cloud
erlang-sasl.x86_64                            19.3.6.4-1.el7                              @centos-cloud
erlang-sd_notify.x86_64                       1.0-2.el7                                   @centos-cloud
erlang-snmp.x86_64                            19.3.6.4-1.el7                              @centos-cloud
erlang-ssl.x86_64                             19.3.6.4-1.el7                              @centos-cloud
erlang-stdlib.x86_64                          19.3.6.4-1.el7                              @centos-cloud
erlang-syntax_tools.x86_64                    19.3.6.4-1.el7                              @centos-cloud
erlang-tools.x86_64                           19.3.6.4-1.el7                              @centos-cloud
erlang-xmerl.x86_64                           19.3.6.4-1.el7                              @centos-cloud
etcd.x86_64                                   3.3.11-2.el7.centos                         @centos-extras
ethtool.x86_64                                2:4.8-10.el7                                installed
euca2ools.noarch                              3.4.1-1.el7                                 @epel
expat.x86_64                                  2.1.0-11.el7                                installed
facter.x86_64                                 1:3.9.3-7.el7                               @centos-cloud
file.x86_64                                   5.11-36.el7                                 installed
file-libs.x86_64                              5.11-36.el7                                 installed
filesystem.x86_64                             3.2-25.el7                                  installed
findutils.x86_64                              1:4.5.11-6.el7                              installed
fipscheck.x86_64                              1.4.1-6.el7                                 installed
fipscheck-lib.x86_64                          1.4.1-6.el7                                 installed
fontconfig.x86_64                             2.13.0-4.3.el7                              @centos-base
fontpackages-filesystem.noarch                1.44-8.el7                                  @centos-base
freetype.x86_64                               2.8-14.el7                                  installed
fuse-libs.x86_64                              2.9.2-11.el7                                @centos-base
galera.x86_64                                 25.3.16-3.el7                               @centos-cloud
gawk.x86_64                                   4.0.2-4.el7_3.1                             installed
gd.x86_64                                     2.0.35-26.el7                               @centos-base
gdbm.x86_64                                   1.10-8.el7                                  installed
gdisk.x86_64                                  0.8.10-3.el7                                @centos-base
genisoimage.x86_64                            1.1.11-25.el7                               @centos-base
gettext.x86_64                                0.19.8.1-3.el7                              installed
gettext-libs.x86_64                           0.19.8.1-3.el7                              installed
git.x86_64                                    1.8.3.1-23.el7_8                            @centos-updates
glib2.x86_64                                  2.56.1-5.el7                                installed
glibc.x86_64                                  2.17-307.el7.1                              installed
glibc-common.x86_64                           2.17-307.el7.1                              installed
glusterfs.x86_64                              6.0-29.el7                                  @centos-base
glusterfs-api.x86_64                          6.0-29.el7                                  @centos-base
glusterfs-client-xlators.x86_64               6.0-29.el7                                  @centos-base
glusterfs-libs.x86_64                         6.0-29.el7                                  @centos-base
gmp.x86_64                                    1:6.0.0-15.el7                              installed
gnupg2.x86_64                                 2.0.22-5.el7_5                              installed
gnutls.x86_64                                 3.3.29-9.el7_6                              @centos-base
gobject-introspection.x86_64                  1.56.1-1.el7                                installed
gperftools-libs.x86_64                        2.6.1-1.el7                                 @centos-base
gpgme.x86_64                                  1.3.2-5.el7                                 installed
gpm-libs.x86_64                               1.20.7-6.el7                                @centos-base
grep.x86_64                                   2.20-3.el7                                  installed
groff-base.x86_64                             1.22.2-8.el7                                installed
grub2.x86_64                                  1:2.02-0.86.el7.centos                      @centos-updates
grub2-common.noarch                           1:2.02-0.86.el7.centos                      @centos-updates
grub2-pc.x86_64                               1:2.02-0.86.el7.centos                      @centos-updates
grub2-pc-modules.noarch                       1:2.02-0.86.el7.centos                      @centos-updates
grub2-tools.x86_64                            1:2.02-0.86.el7.centos                      @centos-updates
grub2-tools-extra.x86_64                      1:2.02-0.86.el7.centos                      @centos-updates
grub2-tools-minimal.x86_64                    1:2.02-0.86.el7.centos                      @centos-updates
grubby.x86_64                                 8.28-26.el7                                 installed
gssproxy.x86_64                               0.7.0-28.el7                                installed
gzip.x86_64                                   1.5-10.el7                                  installed
haproxy.x86_64                                1.5.18-9.el7                                @centos-base
hardlink.x86_64                               1:1.0-19.el7                                installed
hostcli.noarch                                c2.g9a52ce0-1.el7.centos.ta                 @akraino-ta
hostname.x86_64                               3.13-3.el7_7.1                              installed
httpd.x86_64                                  2.4.6-93.el7.centos                         @centos-base
httpd-tools.x86_64                            2.4.6-93.el7.centos                         @centos-base
hw-detector.noarch                            c7.gd3defb5-1.el7.centos.ta                 @akraino-ta
hwdata.x86_64                                 0.252-9.5.el7                               installed
image-provision.noarch                        c7.g9ae9036-1.el7.centos.ta                 @akraino-ta
info.x86_64                                   5.1-5.el7                                   installed
infra-ansible.noarch                          c41.g76de2b3-1.el7.centos.ta                @akraino-ta
initscripts.x86_64                            9.49.49-1.el7                               installed
inventoryhandlers.noarch                      c35.gc8427f2-1.el7.centos.ta                @akraino-ta
ipa-deployer.x86_64                           c7.gd881d27-1.el7.centos.ta                 @akraino-ta
ipmitool.x86_64                               1.8.18-9.el7_7                              @centos-updates
iproute.x86_64                                4.11.0-25.el7_7.2                           installed
ipset-libs.x86_64                             7.1-1.el7                                   @centos-base
iptables.x86_64                               1.4.21-34.el7                               installed
iptables-services.x86_64                      1.4.21-34.el7                               @centos-base
iputils.x86_64                                20160308-10.el7                             installed
ironic-virtmedia-driver.noarch                c8.g9b864a4-1.el7.centos.ta                 @akraino-ta
irqbalance.x86_64                             3:1.0.7-12.el7                              installed
iscsi-initiator-utils.x86_64                  6.2.0.874-17.el7                            @centos-base
iscsi-initiator-utils-iscsiuio.x86_64         6.2.0.874-17.el7                            @centos-base
jansson.x86_64                                2.10-1.el7                                  installed
jemalloc.x86_64                               3.6.0-1.el7                                 @centos-cloud
jq.x86_64                                     1.6-2.el7                                   @epel
json-c.x86_64                                 0.11-4.el7_0                                installed
kbd.x86_64                                    1.15.5-15.el7                               installed
kbd-legacy.noarch                             1.15.5-15.el7                               installed
kbd-misc.noarch                               1.15.5-15.el7                               installed
keepalived.x86_64                             1.3.5-16.el7                                @centos-base
kernel.x86_64                                 5.4.65-200.el7                              @centos-altarch
kernel-core.x86_64                            5.4.65-200.el7                              @centos-altarch
kernel-modules.x86_64                         5.4.65-200.el7                              @centos-altarch
kernel-tools.x86_64                           5.4.65-200.el7                              @centos-altarch
kernel-tools-libs.x86_64                      5.4.65-200.el7                              @centos-altarch
kexec-tools.x86_64                            2.0.15-43.el7                               installed
keyutils.x86_64                               1.5.8-3.el7                                 installed
keyutils-libs.x86_64                          1.5.8-3.el7                                 installed
keyutils-libs-devel.x86_64                    1.5.8-3.el7                                 @centos-base
kmod.x86_64                                   20-28.el7                                   installed
kmod-libs.x86_64                              20-28.el7                                   installed
kpartx.x86_64                                 0.4.9-131.el7                               installed
krb5-devel.x86_64                             1.15.1-46.el7                               @centos-base
krb5-libs.x86_64                              1.15.1-46.el7                               installed
leatherman.x86_64                             1.3.0-9.el7                                 @centos-cloud
less.x86_64                                   458-9.el7                                   installed
leveldb.x86_64                                1.12.0-11.el7                               @epel
libX11.x86_64                                 1.6.7-2.el7                                 @centos-base
libX11-common.noarch                          1.6.7-2.el7                                 @centos-base
libXau.x86_64                                 1.0.8-2.1.el7                               @centos-base
libXpm.x86_64                                 3.5.12-1.el7                                @centos-base
libacl.x86_64                                 2.2.51-15.el7                               installed
libaio.x86_64                                 0.3.109-13.el7                              @centos-base
libassuan.x86_64                              2.1.0-3.el7                                 installed
libattr.x86_64                                2.4.46-13.el7                               installed
libbabeltrace.x86_64                          1.2.4-3.1.el7                               @centos-ceph
libbasicobjects.x86_64                        0.1.1-32.el7                                installed
libblkid.x86_64                               2.23.2-63.el7                               installed
libcap.x86_64                                 2.22-11.el7                                 installed
libcap-ng.x86_64                              0.7.5-4.el7                                 installed
libcephfs2.x86_64                             2:12.2.11-0.el7                             @centos-ceph
libcgroup.x86_64                              0.41-21.el7                                 installed
libcollection.x86_64                          0.7.0-32.el7                                installed
libcom_err.x86_64                             1.42.9-17.el7                               installed
libcom_err-devel.x86_64                       1.42.9-17.el7                               @centos-base
libcroco.x86_64                               0.6.12-4.el7                                installed
libcurl.x86_64                                7.29.0-57.el7_8.1                           @centos-updates
libdaemon.x86_64                              0.14-7.el7                                  installed
libdb.x86_64                                  5.3.21-25.el7                               installed
libdb-utils.x86_64                            5.3.21-25.el7                               installed
libedit.x86_64                                3.0-12.20121213cvs.el7                      installed
libestr.x86_64                                0.1.9-2.el7                                 installed
libevent.x86_64                               2.0.21-4.el7                                installed
libfastjson.x86_64                            0.99.4-3.el7                                installed
libffi.x86_64                                 3.0.13-19.el7                               installed
libgcc.x86_64                                 4.8.5-39.el7                                installed
libgcrypt.x86_64                              1.5.3-14.el7                                installed
libgomp.x86_64                                4.8.5-39.el7                                installed
libgpg-error.x86_64                           1.12-3.el7                                  installed
libibverbs.x86_64                             22.4-4.el7_8                                @centos-updates
libicu.x86_64                                 50.2-4.el7_7                                @centos-updates
libidn.x86_64                                 1.28-4.el7                                  installed
libini_config.x86_64                          1.3.1-32.el7                                installed
libiscsi.x86_64                               1.9.0-7.el7                                 @centos-base
libjpeg-turbo.x86_64                          1.2.90-8.el7                                @centos-base
libkadm5.x86_64                               1.15.1-46.el7                               @centos-base
libmnl.x86_64                                 1.0.3-7.el7                                 installed
libmount.x86_64                               2.23.2-63.el7                               installed
libndp.x86_64                                 1.2-9.el7                                   installed
libnetfilter_conntrack.x86_64                 1.0.6-1.el7_3                               installed
libnfnetlink.x86_64                           1.0.1-4.el7                                 installed
libnfsidmap.x86_64                            0.25-19.el7                                 installed
libnl3.x86_64                                 3.2.28-4.el7                                installed
libnl3-cli.x86_64                             3.2.28-4.el7                                installed
libpath_utils.x86_64                          0.2.1-32.el7                                installed
libpcap.x86_64                                14:1.5.3-12.el7                             @centos-base
libpipeline.x86_64                            1.2.3-3.el7                                 installed
libpng.x86_64                                 2:1.5.13-7.el7_2                            installed
libpwquality.x86_64                           1.2.3-5.el7                                 installed
librados2.x86_64                              2:12.2.11-0.el7                             @centos-ceph
libradosstriper1.x86_64                       2:12.2.11-0.el7                             @centos-ceph
librbd1.x86_64                                2:12.2.11-0.el7                             @centos-ceph
libref_array.x86_64                           0.1.5-32.el7                                installed
librgw2.x86_64                                2:12.2.11-0.el7                             @centos-ceph
libseccomp.x86_64                             2.3.1-4.el7                                 installed
libselinux.x86_64                             2.5-15.el7                                  installed
libselinux-devel.x86_64                       2.5-15.el7                                  @centos-base
libselinux-python.x86_64                      2.5-15.el7                                  installed
libselinux-utils.x86_64                       2.5-15.el7                                  installed
libsemanage.x86_64                            2.5-14.el7                                  installed
libsemanage-python.x86_64                     2.5-14.el7                                  installed
libsepol.x86_64                               2.5-10.el7                                  installed
libsepol-devel.x86_64                         2.5-10.el7                                  @centos-base
libsmartcols.x86_64                           2.23.2-63.el7                               installed
libss.x86_64                                  1.42.9-17.el7                               installed
libssh2.x86_64                                1.8.0-3.el7                                 installed
libstdc++.x86_64                              4.8.5-39.el7                                installed
libsysfs.x86_64                               2.1.0-16.el7                                installed
libtasn1.x86_64                               4.10-1.el7                                  installed
libteam.x86_64                                1.29-1.el7                                  installed
libtirpc.x86_64                               0.2.4-0.16.el7                              installed
libtomcrypt.x86_64                            1.17-33.20170623gitcd6e602.el7              @centos-cloud
libtommath.x86_64                             1.0-8.el7                                   @centos-cloud
libunistring.x86_64                           0.9.3-9.el7                                 installed
libusal.x86_64                                1.1.11-25.el7                               @centos-base
libuser.x86_64                                0.60-9.el7                                  installed
libutempter.x86_64                            1.1.6-4.el7                                 installed
libuuid.x86_64                                2.23.2-63.el7                               installed
libverto.x86_64                               0.2.5-4.el7                                 installed
libverto-devel.x86_64                         0.2.5-4.el7                                 @centos-base
libverto-libevent.x86_64                      0.2.5-4.el7                                 installed
libvirt-libs.x86_64                           4.5.0-33.el7_8.1                            @centos-updates
libvirt-python.x86_64                         4.5.0-1.el7                                 @centos-base
libxcb.x86_64                                 1.13-1.el7                                  @centos-base
libxml2.x86_64                                2.9.1-6.el7.4                               installed
libxml2-python.x86_64                         2.9.1-6.el7.4                               installed
libxslt.x86_64                                1.1.28-5.el7                                @centos-base
libyaml.x86_64                                0.1.4-11.el7_0                              installed
linux-firmware.noarch                         20191203-76.gite8a0f4c.el7                  @centos-base
lksctp-tools.x86_64                           1.0.17-2.el7                                @centos-base
lm_sensors-libs.x86_64                        3.4.0-8.20160601gitf9185e5.el7              @centos-base
lockcli.noarch                                c3.g54aed66-1.el7.centos.ta                 @akraino-ta
logrotate.x86_64                              3.8.6-19.el7                                installed
lshw.x86_64                                   B.02.18-14.el7                              installed
lsof.x86_64                                   4.87-6.el7                                  @centos-base
lttng-ust.x86_64                              2.10.0-1.el7                                @centos-ceph
lua.x86_64                                    5.1.4-15.el7                                installed
lvm2.x86_64                                   7:2.02.186-7.el7_8.2                        @centos-updates
lvm2-libs.x86_64                              7:2.02.186-7.el7_8.2                        @centos-updates
lz4.x86_64                                    1.7.5-3.el7                                 installed
lzo.x86_64                                    2.06-8.el7                                  installed
m2crypto.x86_64                               0.21.1-17.el7                               @centos-base
mailcap.noarch                                2.1.41-2.el7                                @centos-base
make.x86_64                                   1:3.82-24.el7                               installed
man-db.x86_64                                 2.6.3-11.el7                                installed
mariadb.x86_64                                3:10.1.20-2.el7                             @centos-cloud
mariadb-common.x86_64                         3:10.1.20-2.el7                             @centos-cloud
mariadb-config.x86_64                         3:10.1.20-2.el7                             @centos-cloud
mariadb-devel.x86_64                          3:10.1.20-2.el7                             @centos-cloud
mariadb-errmsg.x86_64                         3:10.1.20-2.el7                             @centos-cloud
mariadb-libs.x86_64                           3:10.1.20-2.el7                             @centos-cloud
mariadb-server.x86_64                         3:10.1.20-2.el7                             @centos-cloud
mariadb-server-galera.x86_64                  3:10.1.20-2.el7                             @centos-cloud
memcached.x86_64                              1.5.6-1.el7                                 @centos-cloud
mod_wsgi.x86_64                               3.4-18.el7                                  @centos-base
monitoring.noarch                             c3.g6ee5a86-1.el7.centos.ta                 @akraino-ta
mozjs17.x86_64                                17.0.0-20.el7                               installed
ncurses.x86_64                                5.9-14.20130511.el7_4                       installed
ncurses-base.noarch                           5.9-14.20130511.el7_4                       installed
ncurses-libs.x86_64                           5.9-14.20130511.el7_4                       installed
net-snmp-agent-libs.x86_64                    1:5.7.2-48.el7_8.1                          @centos-updates
net-snmp-libs.x86_64                          1:5.7.2-48.el7_8.1                          @centos-updates
net-tools.x86_64                              2.0-0.25.20131004git.el7                    installed
nettle.x86_64                                 2.7.1-8.el7                                 @centos-base
newt.x86_64                                   0.52.15-4.el7                               installed
newt-python.x86_64                            0.52.15-4.el7                               installed
nginx.x86_64                                  1:1.16.1-2.el7                              @epel
nginx-all-modules.noarch                      1:1.16.1-2.el7                              @epel
nginx-filesystem.noarch                       1:1.16.1-2.el7                              @epel
nginx-mod-http-image-filter.x86_64            1:1.16.1-2.el7                              @epel
nginx-mod-http-perl.x86_64                    1:1.16.1-2.el7                              @epel
nginx-mod-http-xslt-filter.x86_64             1:1.16.1-2.el7                              @epel
nginx-mod-mail.x86_64                         1:1.16.1-2.el7                              @epel
nginx-mod-stream.x86_64                       1:1.16.1-2.el7                              @epel
nmap-ncat.x86_64                              2:6.40-19.el7                               @centos-base
nspr.x86_64                                   4.21.0-1.el7                                installed
nss.x86_64                                    3.44.0-7.el7_7                              installed
nss-pem.x86_64                                1.0.3-7.el7                                 installed
nss-softokn.x86_64                            3.44.0-8.el7_7                              installed
nss-softokn-freebl.x86_64                     3.44.0-8.el7_7                              installed
nss-sysinit.x86_64                            3.44.0-7.el7_7                              installed
nss-tools.x86_64                              3.44.0-7.el7_7                              installed
nss-util.x86_64                               3.44.0-4.el7_7                              installed
ntp.x86_64                                    4.2.6p5-29.el7.centos.2                     @centos-updates
ntpdate.x86_64                                4.2.6p5-29.el7.centos.2                     @centos-updates
numactl-libs.x86_64                           2.0.12-5.el7                                installed
oniguruma.x86_64                              6.8.2-1.el7                                 @epel
openldap.x86_64                               2.4.44-21.el7_6                             installed
openssh.x86_64                                7.4p1-21.el7                                installed
openssh-clients.x86_64                        7.4p1-21.el7                                installed
openssh-server.x86_64                         7.4p1-21.el7                                installed
openssl.x86_64                                1:1.0.2k-19.el7                             installed
openssl-devel.x86_64                          1:1.0.2k-19.el7                             @centos-base
openssl-libs.x86_64                           1:1.0.2k-19.el7                             installed
openstack-ansible.noarch                      17.0.2-1.el7.centos.ta.1                    @akraino-ta
openstack-ansible-galera_client.noarch        17.0.2-1.el7.centos.ta.1                    @akraino-ta
openstack-ansible-galera_server.noarch        17.0.2-1.el7.centos.ta.2                    @akraino-ta
openstack-ansible-haproxy_server.noarch       17.0.2-1.el7.centos.ta.1                    @akraino-ta
openstack-ansible-memcached_server.noarch     17.0.2-1.el7.centos.ta.1                    @akraino-ta
openstack-ansible-openstack_openrc.noarch     17.0.2-1.el7.centos.ta.1                    @akraino-ta
openstack-ansible-os_ironic.noarch            17.0.2-1.el7.centos.ta.1                    @akraino-ta
openstack-ansible-os_keystone.noarch          17.0.2-1.el7.centos.ta.1                    @akraino-ta
openstack-ansible-plugins.noarch              17.0.2-1.el7.centos.ta.1                    @akraino-ta
openstack-ansible-rabbitmq_server.noarch      17.0.2-1.el7.centos.ta.1                    @akraino-ta
openstack-ansible-rsyslog_client.noarch       17.0.2-1.el7.centos.ta.1                    @akraino-ta
openstack-ironic-api.noarch                   1:10.1.4-1.el7.centos.ta.2                  @akraino-ta
openstack-ironic-common.noarch                1:10.1.4-1.el7.centos.ta.2                  @akraino-ta
openstack-ironic-conductor.noarch             1:10.1.4-1.el7.centos.ta.2                  @akraino-ta
openstack-ironic-inspector.noarch             7.2.4-1.el7                                 @centos-cloud
openstack-keystone.noarch                     1:13.0.4-1.el7                              @centos-cloud
openvswitch.x86_64                            1:2.11.0-4.el7                              @centos-cloud
os-net-config.noarch                          10.4.1-0.20191003.14e46a5.el7.centos.ta.1   @akraino-ta
os-prober.x86_64                              1.58-9.el7                                  installed
p11-kit.x86_64                                0.23.5-3.el7                                installed
p11-kit-trust.x86_64                          0.23.5-3.el7                                installed
pam.x86_64                                    1.1.8-23.el7                                installed
parted.x86_64                                 3.1-32.el7                                  installed
partfs_rootdisk.noarch                        c6.gbf14d32-1.el7.centos.ta                 @akraino-ta
passwd.x86_64                                 0.79-6.el7                                  installed
pciutils.x86_64                               3.5.1-3.el7                                 @centos-base
pciutils-libs.x86_64                          3.5.1-3.el7                                 installed
pcre.x86_64                                   8.32-17.el7                                 installed
pcre-devel.x86_64                             8.32-17.el7                                 @centos-base
perl.x86_64                                   4:5.16.3-295.el7                            @centos-base
perl-Carp.noarch                              1.26-244.el7                                @centos-base
perl-Compress-Raw-Bzip2.x86_64                2.061-3.el7                                 @centos-base
perl-Compress-Raw-Zlib.x86_64                 1:2.061-4.el7                               @centos-base
perl-DBD-MySQL.x86_64                         4.023-6.el7                                 @centos-base
perl-DBI.x86_64                               1.627-4.el7                                 @centos-base
perl-Data-Dumper.x86_64                       2.145-3.el7                                 @centos-base
perl-Encode.x86_64                            2.51-7.el7                                  @centos-base
perl-Error.noarch                             1:0.17020-2.el7                             @centos-base
perl-Exporter.noarch                          5.68-3.el7                                  @centos-base
perl-File-Path.noarch                         2.09-2.el7                                  @centos-base
perl-File-Temp.noarch                         0.23.01-3.el7                               @centos-base
perl-Filter.x86_64                            1.49-3.el7                                  @centos-base
perl-Getopt-Long.noarch                       2.40-3.el7                                  @centos-base
perl-Git.noarch                               1.8.3.1-23.el7_8                            @centos-updates
perl-HTTP-Tiny.noarch                         0.033-3.el7                                 @centos-base
perl-IO-Compress.noarch                       2.061-2.el7                                 @centos-base
perl-Net-Daemon.noarch                        0.48-5.el7                                  @centos-base
perl-PathTools.x86_64                         3.40-5.el7                                  @centos-base
perl-PlRPC.noarch                             0.2020-14.el7                               @centos-base
perl-Pod-Escapes.noarch                       1:1.04-295.el7                              @centos-base
perl-Pod-Perldoc.noarch                       3.20-4.el7                                  @centos-base
perl-Pod-Simple.noarch                        1:3.28-4.el7                                @centos-base
perl-Pod-Usage.noarch                         1.63-3.el7                                  @centos-base
perl-Scalar-List-Utils.x86_64                 1.27-248.el7                                @centos-base
perl-Socket.x86_64                            2.010-5.el7                                 @centos-base
perl-Storable.x86_64                          2.45-3.el7                                  @centos-base
perl-TermReadKey.x86_64                       2.30-20.el7                                 @centos-base
perl-Text-ParseWords.noarch                   3.29-4.el7                                  @centos-base
perl-Time-HiRes.x86_64                        4:1.9725-3.el7                              @centos-base
perl-Time-Local.noarch                        1.2300-2.el7                                @centos-base
perl-constant.noarch                          1.27-2.el7                                  @centos-base
perl-libs.x86_64                              4:5.16.3-295.el7                            @centos-base
perl-macros.x86_64                            4:5.16.3-295.el7                            @centos-base
perl-parent.noarch                            1:0.225-244.el7                             @centos-base
perl-podlators.noarch                         2.5.1-3.el7                                 @centos-base
perl-threads.x86_64                           1.87-4.el7                                  @centos-base
perl-threads-shared.x86_64                    1.43-6.el7                                  @centos-base
pinentry.x86_64                               0.8.1-17.el7                                installed
pkgconfig.x86_64                              1:0.27.1-4.el7                              installed
policycoreutils.x86_64                        2.5-34.el7                                  installed
policycoreutils-python.x86_64                 2.5-34.el7                                  installed
polkit.x86_64                                 0.112-26.el7                                installed
polkit-pkla-compat.x86_64                     0.1-4.el7                                   installed
popt.x86_64                                   1.13-16.el7                                 installed
procps-ng.x86_64                              3.3.10-27.el7                               installed
product-manifest.noarch                       321-2.el7.centos.ta                         @localrepo
psmisc.x86_64                                 22.20-16.el7                                @centos-base
pth.x86_64                                    2.0.7-23.el7                                installed
pygpgme.x86_64                                0.3-9.el7                                   installed
pyliblzma.x86_64                              0.5.3-11.el7                                installed
pysendfile.x86_64                             2.0.0-5.el7                                 @centos-cloud
pyserial.noarch                               2.6-6.el7                                   installed
python.x86_64                                 2.7.5-88.el7                                installed
python-IPy.noarch                             0.75-6.el7                                  installed
python-UcsSdk.noarch                          0.8.2.5-1.el7                               @centos-cloud
python-aniso8601.noarch                       0.82-3.el7                                  @epel
python-anyjson.noarch                         0.3.3-3.el7                                 @centos-cloud
python-backports.x86_64                       1.0-8.el7                                   installed
python-backports-ssl_match_hostname.noarch    3.5.0.1-1.el7                               installed
python-beaker.noarch                          1.5.4-10.el7                                @centos-base
python-beautifulsoup4.noarch                  4.6.0-1.el7                                 @centos-cloud
python-cephfs.x86_64                          2:12.2.11-0.el7                             @centos-ceph
python-chardet.noarch                         2.2.1-3.el7                                 installed
python-cherrypy.noarch                        3.2.2-4.el7                                 @centos-base
python-cmd2.noarch                            0.6.8-8.el7                                 @centos-cloud
python-configobj.noarch                       4.7.2-7.el7                                 installed
python-configparser.noarch                    4.0.2-2.el7                                 @epel
python-construct.noarch                       2.8.10-1.el7                                @centos-cloud
python-contextlib2.noarch                     0.5.1-3.el7                                 @epel
python-decorator.noarch                       3.4.0-3.el7                                 installed
python-django-bash-completion.noarch          1.11.27-1.el7                               @epel
python-dns.noarch                             1.15.0-5.el7                                @centos-cloud
python-dogpile-cache.noarch                   0.6.2-1.el7                                 @centos-cloud
python-dogpile-core.noarch                    0.4.1-2.el7                                 @centos-cloud
python-dracclient.noarch                      1.6.0-1.el7                                 @centos-cloud
python-editor.noarch                          0.4-4.el7                                   @centos-cloud
python-enum34.noarch                          1.0.4-1.el7                                 @centos-base
python-extras.noarch                          1.0.0-2.el7                                 @epel
python-flask.noarch                           1:0.10.1-5.el7_7                            @centos-extras
python-gobject-base.x86_64                    3.22.0-1.el7_4.1                            installed
python-ilorest-library.x86_64                 v2.3.1.29.gf6dae68-1.el7.centos.ta.1        @akraino-ta
python-iniparse.noarch                        0.4-9.el7                                   installed
python-inotify.noarch                         0.9.4-4.el7                                 @centos-base
python-ipaddr.noarch                          2.1.11-2.el7                                @centos-base
python-ipaddress.noarch                       1.0.16-3.el7                                @centos-cloud
python-ironic-inspector-client.noarch         3.1.2-1.el7                                 @centos-cloud
python-ironic-lib.noarch                      2.12.4-1.el7                                @centos-cloud
python-itsdangerous.noarch                    0.23-2.el7                                  @centos-extras
python-jsonpath-rw.noarch                     1.2.3-2.el7                                 @centos-cloud
python-jwcrypto.noarch                        0.4.2-1.el7                                 @centos-base
python-kazoo.noarch                           2.2.1-1.el7                                 @centos-cloud
python-keyring.noarch                         5.7.1-1.el7                                 @centos-cloud
python-keystone.noarch                        1:13.0.4-1.el7                              @centos-cloud
python-kitchen.noarch                         1.1.1-5.el7                                 installed
python-ldap.x86_64                            2.4.15-2.el7                                @centos-base
python-ldappool.noarch                        1.0-4.el7                                   @centos-cloud
python-libs.x86_64                            2.7.5-88.el7                                installed
python-linecache2.noarch                      1.0.0-1.el7                                 @centos-cloud
python-linux-procfs.noarch                    0.4.11-4.el7                                installed
python-logutils.noarch                        0.3.3-3.el7                                 @centos-ceph
python-lxml.x86_64                            3.2.1-4.el7                                 @centos-base
python-mako.noarch                            0.8.1-2.el7                                 @centos-base
python-memcached.noarch                       1.58-1.el7                                  @centos-cloud
python-migrate.noarch                         0.11.0-1.el7                                @centos-cloud
python-monotonic.noarch                       0.6-1.el7                                   @centos-cloud
python-netifaces.x86_64                       0.10.4-3.el7                                @centos-base
python-openstackclient-lang.noarch            3.14.3-1.el7                                @centos-cloud
python-oslo-cache-lang.noarch                 1.28.1-1.el7                                @centos-cloud
python-oslo-concurrency-lang.noarch           3.25.1-1.el7                                @centos-cloud
python-oslo-db-lang.noarch                    4.33.4-1.el7                                @centos-cloud
python-oslo-i18n-lang.noarch                  3.19.0-1.el7                                @centos-cloud
python-oslo-log-lang.noarch                   3.36.0-1.el7                                @centos-cloud
python-oslo-middleware-lang.noarch            3.34.0-1.el7                                @centos-cloud
python-oslo-policy-lang.noarch                1.33.2-1.el7                                @centos-cloud
python-oslo-utils-lang.noarch                 3.35.1-1.el7                                @centos-cloud
python-oslo-versionedobjects-lang.noarch      1.31.3-1.el7                                @centos-cloud
python-paramiko.noarch                        2.1.1-9.el7                                 @centos-base
python-paste.noarch                           1.7.5.1-9.20111221hg1498.el7                @centos-base
python-paste-deploy.noarch                    1.5.2-6.el7                                 @centos-cloud
python-perf.x86_64                            3.10.0-1127.19.1.el7                        @centos-updates
python-ply.noarch                             3.4-11.el7                                  @centos-base
python-prettytable.noarch                     0.7.2-3.el7                                 installed
python-progressbar.noarch                     2.3-4.el7                                   @epel
python-proliantutils.noarch                   2.5.0-1.el7                                 @centos-cloud
python-pycadf-common.noarch                   2.7.0-1.el7                                 @centos-cloud
python-pycparser.noarch                       2.14-1.el7                                  @centos-base
python-pycurl.x86_64                          7.19.0-19.el7                               installed
python-pyudev.noarch                          0.15-9.el7                                  installed
python-rados.x86_64                           2:12.2.11-0.el7                             @centos-ceph
python-rbd.x86_64                             2:12.2.11-0.el7                             @centos-ceph
python-repoze-lru.noarch                      0.4-3.el7                                   @centos-cloud
python-repoze-who.noarch                      2.1-1.el7                                   @centos-cloud
python-requestbuilder.noarch                  0.7.1-1.el7                                 @epel
python-retrying.noarch                        1.2.3-4.el7                                 @centos-cloud
python-rgw.x86_64                             2:12.2.11-0.el7                             @centos-ceph
python-routes.noarch                          2.4.1-1.el7                                 @centos-cloud
python-schedutils.x86_64                      0.4-6.el7                                   installed
python-simplegeneric.noarch                   0.8-7.el7                                   @centos-ceph
python-sqlparse.noarch                        0.1.18-5.el7                                @centos-cloud
python-tempita.noarch                         0.5.1-8.el7                                 @centos-cloud
python-testtools.noarch                       1.8.0-2.el7                                 @centos-cloud
python-unicodecsv.noarch                      0.14.1-4.el7                                @epel
python-unittest2.noarch                       1.1.0-4.el7                                 @epel
python-urlgrabber.noarch                      3.10-10.el7                                 installed
python-waitress.noarch                        0.8.9-5.el7                                 @centos-cloud
python-warlock.noarch                         1.0.1-1.el7                                 @centos-cloud
python-webob.noarch                           1.7.2-2.el7                                 @centos-cloud
python-webtest.noarch                         2.0.23-1.el7                                @centos-cloud
python-werkzeug.noarch                        0.9.1-2.el7                                 @centos-extras
python-wrapt.x86_64                           1.10.8-2.el7                                @centos-cloud
python-zope-interface.x86_64                  4.0.5-4.el7                                 @centos-base
python2-PyMySQL.noarch                        0.9.3-1.el7                                 @epel
python2-alembic.noarch                        0.9.7-1.el7                                 @centos-cloud
python2-amqp.noarch                           2.4.0-1.el7                                 @epel
python2-appdirs.noarch                        1.4.0-4.el7                                 @centos-cloud
python2-asn1crypto.noarch                     0.24.0-7.el7                                @epel
python2-automaton.noarch                      1.14.0-1.el7                                @centos-cloud
python2-babel.noarch                          2.3.4-1.el7                                 @centos-cloud
python2-bcrypt.x86_64                         3.1.6-2.el7                                 @epel
python2-cachetools.noarch                     2.0.1-3.el7                                 @centos-cloud
python2-cffi.x86_64                           1.11.2-1.el7                                @centos-cloud
python2-cinderclient.noarch                   3.5.0-1.el7                                 @centos-cloud
python2-cliff.noarch                          2.11.1-1.el7                                @centos-cloud
python2-crypto.x86_64                         2.6.1-16.el7                                @epel
python2-cryptography.x86_64                   2.1.4-2.el7                                 @centos-cloud
python2-dateutil.noarch                       1:2.6.1-1.el7                               @centos-cloud
python2-debtcollector.noarch                  1.19.0-1.el7                                @centos-cloud
python2-deprecation.noarch                    1.0-3.el7                                   @centos-cloud
python2-django.noarch                         1.11.27-1.el7                               @epel
python2-eventlet.noarch                       0.20.1-6.el7                                @centos-cloud
python2-fasteners.noarch                      0.14.1-6.el7                                @centos-cloud
python2-fixtures.noarch                       3.0.0-7.el7                                 @centos-cloud
python2-flask-restful.noarch                  0.3.5-4.el7                                 @epel
python2-funcsigs.noarch                       1.0.2-4.el7                                 @epel
python2-futures.noarch                        3.1.1-5.el7                                 @centos-base
python2-futurist.noarch                       1.6.0-1.el7                                 @centos-cloud
python2-glanceclient.noarch                   1:2.10.1-1.el7                              @centos-cloud
python2-greenlet.x86_64                       0.4.12-1.el7                                @centos-cloud
python2-idna.noarch                           2.5-1.el7                                   @centos-cloud
python2-ironicclient.noarch                   2.2.1-1.el7.centos.ta                       @akraino-ta
python2-iso8601.noarch                        0.1.11-8.el7                                @epel
python2-jinja2.noarch                         2.10-2.el7                                  @centos-cloud
python2-jmespath.noarch                       0.9.4-2.el7                                 @epel
python2-jsonpatch.noarch                      1.21-1.el7                                  @centos-cloud
python2-jsonpointer.noarch                    1.10-4.el7                                  @centos-cloud
python2-jsonschema.noarch                     2.6.0-2.el7                                 @centos-cloud
python2-keystoneauth1.noarch                  3.4.1-1.el7                                 @centos-cloud
python2-keystoneclient.noarch                 1:3.15.1-1.el7                              @centos-cloud
python2-keystonemiddleware.noarch             4.22.0-1.el7                                @centos-cloud
python2-kombu.noarch                          1:4.2.2-1.el7                               @epel
python2-markupsafe.x86_64                     0.23-16.el7                                 @centos-cloud
python2-mimeparse.noarch                      1.6.0-5.el7                                 @epel
python2-mock.noarch                           2.0.0-1.el7                                 @centos-cloud
python2-msgpack.x86_64                        0.5.6-5.el7                                 @epel
python2-munch.noarch                          2.2.0-2.el7                                 @centos-cloud
python2-netaddr.noarch                        0.7.19-5.el7                                @centos-cloud
python2-neutronclient.noarch                  6.7.0-1.el7                                 @centos-cloud
python2-novaclient.noarch                     1:10.1.1-1.el7                              @centos-cloud
python2-oauthlib.noarch                       2.0.1-8.el7                                 @centos-base
python2-openstackclient.noarch                3.14.3-1.el7                                @centos-cloud
python2-openstacksdk.noarch                   0.11.4-1.el7                                @centos-cloud
python2-os-client-config.noarch               1.29.0-1.el7                                @centos-cloud
python2-os-service-types.noarch               1.1.0-1.el7                                 @centos-cloud
python2-os-traits.noarch                      0.5.0-1.el7                                 @centos-cloud
python2-osc-lib.noarch                        1.9.0-1.el7                                 @centos-cloud
python2-oslo-cache.noarch                     1.28.1-1.el7                                @centos-cloud
python2-oslo-concurrency.noarch               3.25.1-1.el7                                @centos-cloud
python2-oslo-config.noarch                    2:5.2.1-1.el7                               @centos-cloud
python2-oslo-context.noarch                   2.20.0-1.el7                                @centos-cloud
python2-oslo-db.noarch                        4.33.4-1.el7                                @centos-cloud
python2-oslo-i18n.noarch                      3.19.0-1.el7                                @centos-cloud
python2-oslo-log.noarch                       3.36.0-1.el7                                @centos-cloud
python2-oslo-messaging.noarch                 5.35.6-1.el7                                @centos-cloud
python2-oslo-middleware.noarch                3.34.0-1.el7                                @centos-cloud
python2-oslo-policy.noarch                    1.33.2-1.el7                                @centos-cloud
python2-oslo-reports.noarch                   1.26.0-1.el7                                @centos-cloud
python2-oslo-rootwrap.noarch                  5.13.0-1.el7                                @centos-cloud
python2-oslo-serialization.noarch             2.24.0-1.el7                                @centos-cloud
python2-oslo-service.noarch                   1.29.1-1.el7                                @centos-cloud
python2-oslo-utils.noarch                     3.35.1-1.el7                                @centos-cloud
python2-oslo-versionedobjects.noarch          1.31.3-1.el7                                @centos-cloud
python2-osprofiler.noarch                     1.15.2-1.el7                                @centos-cloud
python2-passlib.noarch                        1.7.1-1.el7                                 @epel
python2-pbr.noarch                            3.1.1-8.el7                                 @centos-cloud
python2-pecan.noarch                          1.1.2-1.el7                                 @centos-ceph
python2-peewee.x86_64                         2.10.2-3.el7.centos.ta                      @akraino-ta
python2-pika.noarch                           0.10.0-10.el7                               @epel
python2-pika_pool.noarch                      0.1.3-3.el7                                 @centos-cloud
python2-pip.noarch                            8.1.2-14.el7                                @epel
python2-psutil.x86_64                         5.6.7-1.el7                                 @epel
python2-pyOpenSSL.noarch                      17.3.0-3.el7                                @centos-cloud
python2-pyasn1.noarch                         0.1.9-7.el7                                 @centos-base
python2-pycadf.noarch                         2.7.0-1.el7                                 @centos-cloud
python2-pyghmi.noarch                         1.0.22-1.el7                                @centos-cloud
python2-pyngus.noarch                         2.3.0-1.el7                                 @epel
python2-pyparsing.noarch                      2.1.10-7.el7                                @centos-cloud
python2-pysaml2.noarch                        3.0.2-2.el7                                 @centos-cloud
python2-pysnmp.noarch                         4.3.2-3.el7                                 @centos-cloud
python2-pysocks.noarch                        1.6.8-7.el7                                 @epel
python2-python-etcd.noarch                    0.4.3-5.el7                                 @centos-cloud
python2-qpid-proton.x86_64                    0.31.0-3.el7                                @epel
python2-redis.noarch                          2.10.6-1.el7                                @epel
python2-requests.noarch                       2.14.2-1.el7                                @centos-cloud
python2-requestsexceptions.noarch             1.4.0-1.el7                                 @centos-cloud
python2-rfc3986.noarch                        1.3.0-1.el7                                 @epel
python2-scciclient.noarch                     0.6.1-1.el7                                 @centos-cloud
python2-scrypt.x86_64                         0.8.0-2.el7                                 @centos-cloud
python2-setuptools.noarch                     22.0.5-1.el7                                @centos-cloud
python2-shade.noarch                          1.27.2-1.el7                                @centos-cloud
python2-simplejson.x86_64                     3.10.0-2.el7                                @epel
python2-singledispatch.noarch                 3.4.0.3-4.el7                               @centos-ceph
python2-six.noarch                            1.10.0-9.el7                                @centos-cloud
python2-sqlalchemy.x86_64                     1.2.2-2.el7                                 @centos-cloud
python2-statsd.noarch                         3.2.1-5.el7                                 @centos-cloud
python2-stevedore.noarch                      1.28.0-1.el7                                @centos-cloud
python2-sushy.noarch                          1.3.4-1.el7                                 @centos-cloud
python2-swiftclient.noarch                    3.5.1-1.el7                                 @centos-cloud
python2-tenacity.noarch                       4.8.0-1.el7                                 @centos-cloud
python2-tooz.noarch                           1.60.1-1.el7                                @centos-cloud
python2-traceback2.noarch                     1.4.0-7.el7                                 @epel
python2-urllib3.noarch                        1.21.1-1.el7                                @centos-cloud
python2-vine.noarch                           1.2.0-1.el7                                 @epel
python2-virtualbmc.noarch                     1.2.0-1.el7                                 @centos-cloud
python2-voluptuous.noarch                     0.10.5-2.el7                                @centos-cloud
python2-wsme.noarch                           0.9.3-1.el7                                 @centos-cloud
python2-zake.noarch                           0.2.2-2.el7                                 @centos-cloud
pytz.noarch                                   2016.10-2.el7                               @centos-base
pyxattr.x86_64                                0.5.1-5.el7                                 installed
qemu-guest-agent.x86_64                       10:2.12.0-3.el7                             installed
qemu-img-ev.x86_64                            10:2.12.0-44.1.el7_8.1                      @centos-kvm
qemu-kvm-common-ev.x86_64                     10:2.12.0-44.1.el7_8.1                      @centos-kvm
qpid-proton-c.x86_64                          0.31.0-3.el7                                @epel
qrencode-libs.x86_64                          3.4.1-3.el7                                 installed
quota.x86_64                                  1:4.01-19.el7                               installed
quota-nls.noarch                              1:4.01-19.el7                               installed
rabbitmq-server.noarch                        3.6.16-1.el7                                @centos-cloud
rdma-core.x86_64                              22.4-4.el7_8                                @centos-updates
readline.x86_64                               6.2-11.el7                                  installed
recuserconfighandlers.noarch                  c35.gc8427f2-1.el7.centos.ta                @akraino-ta
redis.x86_64                                  3.2.12-2.el7                                @epel
rootfiles.noarch                              8.1-11.el7                                  installed
rpcbind.x86_64                                0.2.0-49.el7                                installed
rpm.x86_64                                    4.11.3-43.el7                               installed
rpm-build-libs.x86_64                         4.11.3-43.el7                               installed
rpm-libs.x86_64                               4.11.3-43.el7                               installed
rpm-python.x86_64                             4.11.3-43.el7                               installed
rsync.x86_64                                  3.1.2-10.el7                                installed
rsyslog.x86_64                                8.24.0-52.el7_8.2                           @centos-updates
sed.x86_64                                    4.2.2-6.el7                                 installed
selinux-policy.noarch                         3.13.1-266.el7_8.1                          @centos-updates
selinux-policy-targeted.noarch                3.13.1-266.el7_8.1                          @centos-updates
setools-libs.x86_64                           3.3.8-4.el7                                 installed
setup.noarch                                  2.8.71-11.el7                               installed
sg3_utils.x86_64                              1:1.37-19.el7                               installed
sg3_utils-libs.x86_64                         1:1.37-19.el7                               installed
shadow-utils.x86_64                           2:4.6-5.el7                                 installed
shared-mime-info.x86_64                       1.8-5.el7                                   installed
shellinabox.x86_64                            2.20-5.el7                                  @epel
slang.x86_64                                  2.2.4-11.el7                                installed
snappy.x86_64                                 1.1.0-3.el7                                 installed
socat.x86_64                                  1.7.3.2-2.el7                               @centos-base
sqlite.x86_64                                 3.7.17-8.el7_7.1                            installed
sshpass.x86_64                                1.06-2.el7                                  @centos-extras
start-menu.noarch                             c2.gb375099-1.el7.centos.ta                 @akraino-ta
sudo.x86_64                                   1.8.23-9.el7                                installed
systemd.x86_64                                219-73.el7_8.9                              @centos-updates
systemd-libs.x86_64                           219-73.el7_8.9                              @centos-updates
systemd-sysv.x86_64                           219-73.el7_8.9                              @centos-updates
sysvinit-tools.x86_64                         2.88-14.dsf.el7                             installed
tar.x86_64                                    2:1.26-35.el7                               installed
tcp_wrappers.x86_64                           7.6-77.el7                                  installed
tcp_wrappers-libs.x86_64                      7.6-77.el7                                  installed
tcpdump.x86_64                                14:4.9.2-4.el7_7.1                          @centos-base
traceroute.x86_64                             3:2.0.22-2.el7                              @centos-base
trousers.x86_64                               0.3.14-2.el7                                @centos-base
tuned.noarch                                  2.11.0-8.el7                                installed
tzdata.noarch                                 2020a-1.el7                                 @centos-updates
unbound-libs.x86_64                           1.6.6-5.el7_8                               @centos-updates
userconfighandlers.noarch                     c35.gc8427f2-1.el7.centos.ta                @akraino-ta
userspace-rcu.x86_64                          0.10.0-3.el7                                @centos-ceph
ustr.x86_64                                   1.0.4-16.el7                                installed
util-linux.x86_64                             2.23.2-63.el7                               installed
uwsgi.x86_64                                  2.0.18-8.el7                                @epel
uwsgi-plugin-common.x86_64                    2.0.18-8.el7                                @epel
uwsgi-plugin-python2.x86_64                   2.0.18-8.el7                                @epel
validators.noarch                             c35.gc8427f2-1.el7.centos.ta                @akraino-ta
vim-common.x86_64                             2:7.4.629-6.el7                             @centos-base
vim-enhanced.x86_64                           2:7.4.629-6.el7                             @centos-base
vim-filesystem.x86_64                         2:7.4.629-6.el7                             @centos-base
vim-minimal.x86_64                            2:7.4.629-6.el7                             installed
virt-what.x86_64                              1.18-4.el7                                  installed
wget.x86_64                                   1.14-18.el7_6.1                             @centos-base
which.x86_64                                  2.20-7.el7                                  installed
xfsprogs.x86_64                               4.5.0-20.el7                                installed
xinetd.x86_64                                 2:2.3.15-14.el7                             @centos-base
xz.x86_64                                     5.2.2-1.el7                                 installed
xz-libs.x86_64                                5.2.2-1.el7                                 installed
yajl.x86_64                                   2.0.4-4.el7                                 @centos-base
yaml-cpp.x86_64                               1:0.5.1-2.el7                               @epel
yarf.x86_64                                   c2.g51e80b4-1.el7.centos.ta                 @akraino-ta
yum.noarch                                    3.4.3-167.el7.centos                        installed
yum-metadata-parser.x86_64                    1.1.4-10.el7                                installed
yum-plugin-fastestmirror.noarch               1.1.31-54.el7_8                             @centos-updates
yum-plugin-priorities.noarch                  1.1.31-54.el7_8                             @centos-updates
yum-utils.noarch                              1.1.31-54.el7_8                             @centos-updates
zlib.x86_64                                   1.2.7-18.el7                                installed
zlib-devel.x86_64                             1.2.7-18.el7                                @centos-base


Upgrade Procedures

Currently REC only supports bare metal installation. In place upgrades are not supported. The upgrade procedure is the same as the initial installation procedure documented in the REC Installation Guide.

Release Upstream Compliance

With regard to the Akraino Release Upstream Compliance policy, the REC Continuous Integration (or more specifically the Telco Appliance CI that REC uses) pulls in lots of software from upstream. All the details of what it pulls in and what it does with it is in the form of executable code in the various Gerrit repositories: https://gerrit.akraino.org/r/admin/repos/q/filter:ta

Some software gets pulled in as packages, some software gets compiled from source. REC (actually TA) as a whole is not intended as a fork of anything, it’s purely intended to package and automate the bare metal installation and configuration of all the various software components.

Release Data

Radio Edge Cloud Repository

The Radio Edge Cloud repository is quite small and mostly contains simple workflow scripts that allow the Akraino Regional Controller to perform the installation of the Telco Appliance based bare metal installation used by REC. There have been no changes to the workflow since release 3.

Telco Appliance Repositories

Radio Edge Cloud is primarily composed of code from the following Telco Appliance repositories. The list below shows the changes to each repository since the time of Akraino Release 1 at the end of May.

======================== access-management ========================
No changes since Release 3
======================== ansible-role-ntp ========================
No changes since Release 3
======================== build-tools ========================
Commit 7dca3e0 on Thu Oct 15 12:19:46 2020 -0400      Fix zipp version issue
======================== caas-cpupooler ========================
Commit 0b73036 on Wed Oct 7 09:55:03 2020 +0000       CPU Pooler version updated to 0.3.1
======================== caas-danm ========================
No changes since Release 3
======================== caas-etcd ========================
No changes since Release 3
======================== caas-helm ========================
No changes since Release 3
======================== caas-install ========================
No changes since Release 3
======================== caas-kubedns ========================
No changes since Release 3
======================== caas-kubernetes ========================
Commit 2b8e087 on Tue Nov 3 13:36:27 2020 -0500       Security: disable kubelet debugging handlers flag
======================== caas-lcm ========================
No changes since Release 3
======================== caas-logging ========================
No changes since Release 3
======================== caas-metrics ========================
No changes since Release 3
======================== caas-registry ========================
No changes since Release 3
======================== caas-security ========================
No changes since Release 3
======================== caas-storage ========================
No changes since Release 3
======================== cloudtaf ========================
No changes since Release 3
======================== cm-plugins ========================
No changes since Release 3
======================== config-manager ========================
No changes since Release 3
======================== distributed-state-server ========================
No changes since Release 3
======================== hostcli ========================
No changes since Release 3
======================== hw-detector ========================
No changes since Release 3
======================== image-provision ========================
No changes since Release 3
======================== infra-ansible ========================
Commit 76de2b3 on Fri Sep 18 14:42:10 2020 -0400      FIX: Change ownership of newly-created VGs
Commit d2a34bd on Sun Sep 6 13:37:11 2020 -0400       Remove XFS nobarrier option
======================== ipa-deployer ========================
No changes since Release 3
======================== ironic ========================
No changes since Release 3
======================== ironicclient ========================
No changes since Release 3
======================== ironic-virtmedia-driver ========================
Commit 9b864a4 on Thu Oct 15 15:27:04 2020 +0000      Merge "Boot nodes from virtual, rather than local, CD"
======================== lockcli ========================
======================== manifest ========================
Commit 7fec492 on Thu Oct 8 10:42:59 2020 -0400       Use latest CentOS 7
======================== monitoring ========================
No changes since Release 3
======================== openstack-ansible ========================
No changes since Release 3
======================== openstack-ansible-galera_client ========================
No changes since Release 3
======================== openstack-ansible-galera_server ========================
No changes since Release 3
======================== openstack-ansible-haproxy_server ========================
No changes since Release 3
======================== openstack-ansible-memcached_server ========================
No changes since Release 3
======================== openstack-ansible-openstack_openrc ========================
No changes since Release 3
======================== openstack-ansible-os_ironic ========================
No changes since Release 3
======================== openstack-ansible-os_keystone ========================
No changes since Release 3
======================== openstack-ansible-plugins ========================
No changes since Release 3
======================== openstack-ansible-rabbitmq_server ========================
No changes since Release 3
======================== openstack-ansible-rsyslog_client ========================
No changes since Release 3
======================== os-net-config ========================
No changes since Release 3
======================== python-ilorest-library ========================
No changes since Release 3
======================== python-peewee ========================
No changes since Release 3
======================== remote-installer ========================
Commit d1feeb7 on Mon Oct 19 16:23:09 2020 -0400      Fix: First boot from floppy, not CD-ROM
Commit bd5d485 on Thu Jun 11 10:35:17 2020 +0300      Fix BMCException handling
Commit f67d243 on Tue May 26 18:51:17 2020 +0200      BMC management: Increase BMC reset timeout
======================== rpmbuilder ========================
No changes since Release 3
======================== start-menu ========================
No changes since Release 3
======================== storage ========================
Commit bf14d32 on Mon Sep 21 14:50:59 2020 -0400      Rebalance root disk storage
Commit 6e4495a on Mon Sep 14 09:35:46 2020 -0400      Add MariaDB LV
Commit 81e5092 on Mon Sep 7 18:41:57 2020 +0000       Remove XFS nobarrier option
======================== ta ========================
Commit 5881b39 on Wed Jul 1 11:03:21 2020 -0400       Update INFO.yaml file with committer info
Commit f97916f on Fri Jun 12 13:01:19 2020 -0700      Add INFO.yaml file for TA blueprint
======================== yarf ========================
No changes since Release 3

Known Limitations, Issues and Workarounds

As of this release, as with past REC releases, the bare metal deployment ends just prior to installation of the O-RAN RAN Intelligent Controller (RIC). The installation of the RIC is a separate post-install step following O-RAN-SC's instructions. The REC install provides the automation from bare metal (i.e. no OS installed) up to but not including the RIC install.

References

  • No labels